Forum Upgrade

btkong

Journeyed there and back again
Staff member
#1
I've had some server issues the past day, so you may have had some connection problems. I think those have been resolved (crossing my fingers), but if you can't connect or get a CloudFlare 502 Error screen, this is the reason.

I've heard over the past month the forums have had some strange issues (random redirects, virus alerts, etc). I've deleted the old forum software and plugins and done a brand new forum install of the newest version, so this should fix all issues. I'll be doing a few more updates as well.

However, some of the plugins/addons I had were quite old and outdated. So I have to reinstall some of these, so if some buttons or features are missing, this is why. I'll be adding back the important ones over the next day or so.

Note that version 2 of the forum software is coming out in 1-2 months; this is a big update and several years in the making by the forum developers, so expect some very big forum changes (new look, new features, etc) when I upgrade to version 2 in a month or two.

Any issues with the forum, please post here so I can take a look!
 
Last edited:

Alucard

In the name of the Pizza Lord. Charge!
Staff member
#2
Hey @btkong

I'm having some issues. There's no chat box for me anywhere or link to Chat in the top of the page. I'm not getting any alerts.
And there's this weird issue with New Posts. There would usually be a number, but now I have this:

Capture.PNG


Forgot to add. I'm on Chrome.
Google Chrome is up to date
Version 61.0.3163.100 (Official Build) (64-bit)
 
Last edited:

btkong

Journeyed there and back again
Staff member
#3
Yes, it's because I haven't reinstalled all those plugins yet. I need to get the new version of the chat, reinstall the credit plugins, and the post notification plugin. Over the next couple days, I'll be adding everything back~
 

Sneaky Burrito

Crazy Cat Lady
Staff member
#5
In Firefox, I keep getting some random URL with /install/install/install/blah blah blah at the end when I try to come here and a login screen (not the normal one I would expect to see) and if I log in, it says I don't have admin privileges. (I am in Safari right now.)
 

btkong

Journeyed there and back again
Staff member
#7
Yea, been having major server issues. I'm hoping the recent fix I did today resolves it. The server has been going offline for like 10 hours, usually right as I go to bed (opposite time zone from North America) so I've been waking up to find the server offline.

So it *may* be fixed (server). If not, I'll have to pull out the big guns to fix it.

I still need to install the missing plugins for the forum (credit system, chat, etc), so bear with me on that for a few days.
 

Sneaky Burrito

Crazy Cat Lady
Staff member
#8
Yea, been having major server issues. I'm hoping the recent fix I did today resolves it. The server has been going offline for like 10 hours, usually right as I go to bed (opposite time zone from North America) so I've been waking up to find the server offline.

So it *may* be fixed (server). If not, I'll have to pull out the big guns to fix it.

I still need to install the missing plugins for the forum (credit system, chat, etc), so bear with me on that for a few days.
Aside from the missing plugins, seems much better today than it has the past few days.
 

Anti_Quated

Journeyed there and back again
#10
Today is the first day I've actually gotten access through to the site without a 502/time-out error screen since the 29th. Good to see it's functioning again. Fingers crossed you don't have any more technical issues before the big upgrade Ben.
 

Sneaky Burrito

Crazy Cat Lady
Staff member
#12

btkong

Journeyed there and back again
Staff member
#13
I'll be adding the plugin back this week. Credit system will be back (credits are all there still), and the smiles, chat, etc. I wanted to make sure it was working properly first,w hich it seems it is!
 

btkong

Journeyed there and back again
Staff member
#19
I've been waiting to do the big upgrade guys to version 2 of the forum. For some reason, some of the old plugins (chat, credit system) don't work right now. So I'm hoping the big upgrade will fix this. I'll take a look this weekend and see what I can do though. Some of the smaller plugins (the smily stuff, I can add back)